MGExp

MG Midget Forum

Back to The Oil Pressure Gauge

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

edforrest Avatar
edforrest Ed Forrest
Atlanta Metro, USA   USA
I have 'strung' a new line from the block to the old (duplex" gauge.

As stated previously, this was a 'perfect storm' of an un-primed oil pump and now a bad gauge.

1.) Any ideas on why the gauge is not moving?
--> I tapped the glass/back housing and it's stuck.
--> Clear oil and pressure coming to the gauge.
--> OMG those darned replacements are expensive!!

2.) I am looking at mounting new gauges
--> a 2" gauge does not fit...I mean it will fit on the dash...but it's "tight".
--> Has anyone mounted one in the "foam" padding on the passenger side with any success?

3.) Anyone near Atlanta have one for sale? That works! The washer control I bought ($$$) does not work!!

Thanks to all,. ed

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
sam-i-am Avatar
sam-i-am Sam L
Caledonia, Wisconsin, USA   USA
Hi Ed,

I pulled the padding from my 68 Sprite and added gauges on the passenger side. The only down side is that the passenger side of the dash slants downward so looking at the gauges is not a straight line of site. The only original gauge left is the fuel gauge, the tach and speedo are from Speedhut and the other gauges are from O'Reilly auto parts. Good luck!

Sam.


Attachments:
image.jpeg    18.5 KB
image.jpeg

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster