Website undergoing maintenance, connection may be intermittent
MGExp

MG Midget Forum

clutch slave cylinder repair kit

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

GregLewisTTU Greg Lewis
Austin, TX, USA   USA
So, I have a S-141 clutch slave cylinder (actually 2 of them) for my midget that needs a repair kit and I have 7-232 repair kit from Vic Brit. Both say 7/8" bore.

The rubber washer that was on it (bought new, .067 and .066 jpg) is a very different size than what comes in the kit. Does this washer size really work for repairing this cylinder?

I think the bore on the s-141 cylinder is really .7 and the repair kit they sell at VB is not a match.

Am I doing this all wrong? I'm tired of buying the full slave cylinder.



Edited 1 time(s). Last edit at 2018-04-14 12:43 PM by GregLewisTTU.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

Attachments:
M624-L.jpg    8.4 KB
M624-L.jpg

067.JPG    8.4 KB
Sign In or Register to view this photo
066.JPG    8.4 KB
Sign In or Register to view this photo
pixelsmithusa Avatar
Unless I'm mistaken, the slave cylinder in the 1500 Midgets is a 1" bore, but I think some Spitfires are 7/8". I think you have the wrong kit for yours.



Gerard

http://gerardsgarage.com/


. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster