MGExp

MG Midget Forum

ignition on, everything works, but no power to starter

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

rpmtndweller Richard P
Forest Falls, Ca., USA   USA
Three days ago, I was out driving my '71 Midge 1275, and all was fine. Put her to bed, came out this morning, pulled the choke, turned the key, and NOTHING. All dash lights, horn, turn signals, gen. light,, headlights worked, but no power to the starter, or, as I now recall, to the fuel pump. Consulted Haynes, followed trouble shooting procedures, and NOTHING. All ideas would be welcome.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
58custom Avatar
58custom Tom Crocker
Santa Clarita, SoCal, USA   USA
As regards the fuel pump, unless you checked for voltage at the pump and determined there was none then I would not worry about it just yet. The pump does not operate when line pressure is above a set point. So lets put this topic aside for a moment.

The starter operates when battery current is directed to it via the starter solenoid. It's a relay. Check for voltage at the small wire when the key is in the start position. If no voltage, you can make a quick check by jumpering from the battery + to this point to see if you can trigger the relay (and make the starter turn). If when you turn the key to start you hear a click at the solenoid then the coil inside is working normally but the current is not reaching the starter OR the starter itself is broken. In this condition disconnect all the cables and clean and reattach and try again. Nothing? You can jump battery current from the battery directly across the solenoid cable terminals with a jumper cable or some other thing (safely!). Works? Change solenoid. No workie? Check starter cable then remove starter and bench test.



1969 MG Midget with Datsun A15/5 speed



Edited 1 time(s). Last edit at 2018-04-08 10:51 AM by 58custom.

Kerr Avatar
Kerr Platinum Member Norm Kerr
Ann Arbor, MI, USA   USA
only thing I can add to Tom's direction is to take care when removing the cable from the post on the starter to clean its contacts, inside is a small wire that can be easily broken so hold the lower nut still while you rotate the outer nut to prevent breaking that

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
bev sleet Avatar
bev sleet Bev S
Raunds, Northamptonshire, UK   GBR
another item to check is the engine to bodywork earth strap and clean connections up

Tynwistle Avatar
Tynwistle Silver Member David L
Tacoma, WA, USA   USA
1979 MG Midget "Bruna"
Could be your starter is stuck. Put the car in 4th and rock it a bit. This can sometimes shake it lose. You can also fit a 1/4 inch spinner on the back of the starter and turn it. If it’s stuck, this will release it. If either of these things work, replace the starter. The teeth are probably worn off it in places.

jmac Avatar
jmac Silver Member Jere McSparran
Greenup, IL, USA   USA
1970 MG Midget "Joy Ride"
1978 MG Midget "Therapy"
1978 MG Midget "(SOLD)"
One more thing, it could be the ignition switch. I know that when you turn the switch on all the lights come on, but in order to engage the starter you must continue to turn the key to the start position. There is a possibility that part of the ignition is not making contact when you try to start. This is not likely however, but I didn't see anyone else mention it.
Check ground.
Check solenoid.
Check starter.
Check ignition switch.

Did you resolve this issue? or not?



JMac
JMAC Engine Shop
http://www.jmacengineshop.com

littlecars Avatar
littlecars David Bassett
Nashville, TN, USA   USA
1965 Chevrolet Corvair "Ski Team Transport SOLD!"
1965 MG Midget MkII "Buffoon"
1966 MG Midget MkII "Swiss Cheese...SCRAPPED"
1970 Triumph Spitfire MkIII "Tamara's Turd... SOLD!!!"    & more
x2 what Jere says. Mine was an intermittent problem with the ignition switch with the key in the start position. My original key was worn pretty bad too.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster