MGExp

Todd Morales's Journal

mrales5 Todd Morales

Home Page: Todd Morales   USA
Cottage Hills, IL, USA

Total Posts: 7 Latest Post: 2018-04-11
Table of Contents

Reverse Lamps Not Working

Todd Morales   USA — Posted on The MG Experience
Wednesday April 11, 2018 12:14 PM



. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Member Comments on Journal Entry: Reverse Lamps Not Working   ↵
2018-04-13 09:08:41 # 49702
Comment by Tom Hayden
Todd, I guess my question would be what do you mean by "running power to them and grounding them"? The obvious conclusion is the bulbs are bad, but it depends on where you "ran power" . Did you disconnect the wires at the lamp fixture and connect 12 V and ground to them? How good a ground connection? Have you tested the bulbs ? Tom
2018-04-13 09:55:19 # 49704
Comment by Todd Morales
I ran 12 V to the lamp fixture and grounded to a known good ground. Like I said I was running out of daylight so didn't get deeper into it. I'll do that this weekend. They are brand new bulbs, but still doesn't mean they can't be bad. I've tested many lights on this car, as well as a 77 B I had 10 years ago, so I expected this to work like the others. But then again it is an MG. LOL. My hope was to test the fixture and find it working once I run 12V to it and give it a good ground. Then I would know it was the switch. I still want to check the wiring and make sure they are getting power and a good ground. Hopefully I can do that this weekend.
2018-04-14 00:55:14 # 49712
Comment by Gary Kinslow
2018-04-14 00:56:47 # 49713
Comment by Gary Kinslow

Want to leave a comment or ask the owner a question?
Sign in or register a new account — it's free









Join The Club

Sign in to ask questions, share photos, and access all website features

Your Cars

1974 MG Midget MkIII

Text Size

Larger Smaller
Reset Save

Sponsor Links