Other Vehicles

Welcome! Sign In Register
Please Sign In or Register to Search

High voltage reading

Posted by pacrat1946 
Paul Chalupa
Select one...Ontario, Canada   can
1979 MG MGB

Hi I removed my clock as it died on my 79 mgb and installed a voltage guage in the hole Voltage reads almost 18 volts when engines revs high Thought intially voltage guage ws defective so replaced it Same problem Any suggestions put an voltmeter on to check Reads the same way
Thanks to all in advance
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info
9146 Avatar
rick dentel
yardley, pa, USA   usa

Sounds like a alternator problem. Does your battery smell funny or is it dry?
Paul Chalupa
Select one...Ontario, Canada   can
1979 MG MGB

Battery smell OK and not dry All the guages seem to be normal Starts good Only issue is the high voltage
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info
pcadogan Avatar
pat c
ok, USA   usa
1973 MG MGB "Eliza Jane"

This needs to be on the MG forum so the hordes can all advise....shouldnt be in the other car section
mac townsend Avatar
Fairfield, CA, USA   usa

check calibration on the meter. Compare it's reading to a VOM reading off the battery.



1973 Roadster. A nice 50-footer!
SUs, Datsun 5-speed
MGB Tips and Tricks: www.mgrescue.com
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info

Reply to this topic or post your own questions!

Members Sign In if you've already registered, or

Register a New Account

Registration is free and takes less than a minute

Having trouble posting or changing forum settings?
Check the Forum Help File (FAQ) or contact the webmaster.


Join The Club

Sign in to ask questions, share photos, and access all website features

Adjust Text Size

Larger Smaller
Reset Save