MGExp

MG Engine Swaps Forum

engine running hot

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

billhall Avatar
billhall bill hall
tucson, az, USA   USA
I don't get it, I just put in a new long block 3.4 l v6 engine in my mgb and it runs hotter than the old 3.4 I had in it before. The radiator set up is the same one as the old engine with a new water pump and thermostat. it doesn't get hot all at once it just slowly creeps up. with the old engine it would hold under 200 now it just keeps slowly creeping up. Faster if iam driving hard but driving around 3 three city blocks I get the below picture temperature would sluge build up in the radiator cause this I had it tanked and when I placed it back on the old engine. when I did change the fluid after that it was very brown and rust colored as if it caused crap from the old engine to let loose in the system. I did flush it well before installing in the new engine even left some clr in it for a couple of days. before flushing and installing. I am curious what other peoples 3.4 l conversions operating temp runs at and why it slowly creeps up? thanks any input would be appreciated.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

Attachments:
0B98F691-20E1-4023-85AF-8EF106FD3B63.JPG    42.4 KB
0B98F691-20E1-4023-85AF-8EF106FD3B63.JPG

ohlord Avatar
ohlord Gold Member Rob C
North of Seattle, N.W., USA   USA
1957 Land Rover Series I "EYEYIYI"
1971 MG MGB
1971 MG MGB "Bedouin 2"
Check you timing.
Retarded causes heat issues.

Bump up the timing a few degrees, the book specs are hopelessly outdated.



"I'm a long way gone down this wild road I'm on
It's gonna take me where I'm bound
It's a long way around"



"These are the days that must happen to you"

RD2 Radar/ Electronic Warfare Technician
Vietnam 1969-1972

GMATS Avatar
GMATS GERALD MATLIN
palm beach gardens, florida, USA   USA
You might have some air trapped in the engine. Take off the radiator cap and let the engine run up to temp and see if you get a lot of "burping". If you do it's air and once that stops your temp may be aok.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
billhall Avatar
billhall bill hall
tucson, az, USA   USA
funny that you mention timing I just set it on fast and ideal and I cant remember what I left them at but I believe they where mid range on both. what timing do you suggest Rob?
Gerald I did try burping the radiator I even dropped the passengers side a little lower while on stands to get the neck of the radiator at a higher point it helped a bit I was able to make it around the block 3 times and not 2.
I pulled the radiator later during the day today and dropped it off to get tanked will see if that solves the problem. but it did give me a chance to change the pulley while I was at it now it has Bills water pulley that I had changed to a smooth profile to run on the back of the belt.


Attachments:
694DE545-AB58-4D9E-ACF3-602579139067.JPG    63.2 KB
694DE545-AB58-4D9E-ACF3-602579139067.JPG

cstrong45 Avatar
cstrong45 Silver Member Charles Strong
Bainbridge Island, Washington, USA   USA
at what point does the fan come on?

billhall Avatar
billhall bill hall
tucson, az, USA   USA
They come on at 170 ish

ohlord Avatar
ohlord Gold Member Rob C
North of Seattle, N.W., USA   USA
1957 Land Rover Series I "EYEYIYI"
1971 MG MGB
1971 MG MGB "Bedouin 2"
Distributor timing at idle?
Total all in at ?

After you clean the radiator try approx 3-5 more degrees at 800rpm
And then go road load tune it like distributor ignition fired engine



"I'm a long way gone down this wild road I'm on
It's gonna take me where I'm bound
It's a long way around"



"These are the days that must happen to you"

RD2 Radar/ Electronic Warfare Technician
Vietnam 1969-1972

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
billgknapp Avatar
billgknapp Silver Member Bill Knapp
Rochester, Michigan, USA   USA
1977 MG MGB "Nigel"
I love your gauge faces Bill

billhall Avatar
billhall bill hall
tucson, az, USA   USA
Sorry Rob,
I forget the correct terminology if I haven't recently reviewed it.
total timing was set at 2000 rpm and if I remember correctly I set it a 28 deg.
partial timing was set at 900 rpm at 8 deg, I believe. Both while engine at running temp with the vacuum line to distributor closed off.
I am a little confused with your road load tune comment can you explain it a little further.
Thanks again

Thanks Bill, The gauges are from VDO they all work fine except I haven't been able to get speedometer to work correctly. as soon as I get the overheating issue fixed I will try and reset it again. when I had the trany rebuilt I had the pulse sender checked over so hopefully that will solve that problem.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
260mgb Jim Nichols
Sequim,WA, USA   USA
Bill, Try 10-12 initial, should be around 32-36 total all in at 2500 RPM. I've had better luck running manifold instead of ported vacuum. It must be limited to 8-10 and you will have to slow your idle back down.

ohlord Avatar
ohlord Gold Member Rob C
North of Seattle, N.W., USA   USA
1957 Land Rover Series I "EYEYIYI"
1971 MG MGB
1971 MG MGB "Bedouin 2"
8 is low
Spec is 10 and that's outdated on modern regular fuel.
Bump it up ,adjust idle.

Go out on a steep hill (no traffic) punch the gas at 2500rpm in 3Rd gear .Test response and listen for pinging under
LOAD no pinging try a few more degrees timing
Repete test. When it pings back it down to the last timing it didn't ping.

Your performance will be snappier and your cool will return.
190f-200f operating is dandy

Confirm with infra gun
Compare to gauge reading



"I'm a long way gone down this wild road I'm on
It's gonna take me where I'm bound
It's a long way around"



"These are the days that must happen to you"

RD2 Radar/ Electronic Warfare Technician
Vietnam 1969-1972

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions

Members Sign In   or   Create an Account

Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster