MG Midget Forum

Welcome! Sign In Register
Please Sign In or Register to Search

1500 exhaust popping and hesitating on acceleration

Posted by oldag98 
oldag98 Avatar
Jeff and Brittany Brackenridge
Choctaw, Choctaw, Oklahoma, USA   usa
1975 MG Midget Conversion
1976 MG Midget 1500 "Yellow One"
1977 MG Midget 1500 "Dunkirk"
1979 MG Midget 1500 "Parts Car"

77 midget 1500 with dual HS4's, headers, electronic ignition with vacc adv: I have recently noticed that upon acceleration when the car is cold, i.e. when i first start the car, or restart after cool down of over an hour, I will have a low rpm misfire upon acceleration, a stumble, a popping thru what i believe is the exhaust, the car will hesitate a bit, but within seconds will spool up and pull fine. I am not using the choke when I start the car, as the ambient air temp is pretty warm, but even when it is not warm, I generally do not need to use the choke to start the car. Car does not seem to run rich or lean otherwise, i.e. good plug color and no tail pipe smoke.. Once the car is warm, operating temp, this seems to go away. What might cause this and what other info do you need to help diagnose?
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info
James D
beach, VA, USA   usa
1978 MG MGB "The Bee"

Did this problem happen all of a sudden? Will the engine hold higher rpms on a load or at idle?
oldag98 Avatar
Jeff and Brittany Brackenridge
Choctaw, Choctaw, Oklahoma, USA   usa
1975 MG Midget Conversion
1976 MG Midget 1500 "Yellow One"
1977 MG Midget 1500 "Dunkirk"
1979 MG Midget 1500 "Parts Car"

The problem has been there since last rebuild of the carbs a few months ago. I did not run the carbs prior to rebuilding. The engine/carbs perform fine otherwise, just a popping or hesitating upon acceleration when cold/cool. It idles fine, holds higher rpms, i.e. cruising speed, fine. It is just upon accel that there is some chugging, popping, hesitating that to me feels like an ignition misfire, but ignition has not been touched. I am thinking the issue might be ignition related, or advance related, but might also be carbs too, since I did not notice this with the Weber.
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info
Edmund Billeci
Monterey CA, USA   usa

Is the car equipped with an air pump and check valve for the emissions system? Or are you lucky enough to not have these horrible parts required on your vehicle? If you’re stuck with them like I am you might want to see if your check valve is working properly as it could cause the symptoms you are describing. My 79 Midget is terrible about it until she’s warmed up (hesitates, misfire). I have also had a similar issue come up when my heat riser was not properly attached to the air intake (but that was with the ZS carb).



Edited 1 time(s). Last edit at 06/01/2011 02:35PM by Ed-B.
oldag98 Avatar
Jeff and Brittany Brackenridge
Choctaw, Choctaw, Oklahoma, USA   usa
1975 MG Midget Conversion
1976 MG Midget 1500 "Yellow One"
1977 MG Midget 1500 "Dunkirk"
1979 MG Midget 1500 "Parts Car"

No emissions control items attached to the engine. The vapor line from the tank to the charcoal can is there, though no charcoal can. I am of the opinion that this is choke on the HS4's or advance on the electronic distributor related.
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info
mark w
lost angy, USA   usa

I would say it started after you put those carbs on its the carbs....u sure its the exhaust? Usually popping from the exhaust on accel is from extremely advanced timing, or a seriously messed up ignition system firing on the exhaust stroke somehow.

But with a hesitation im guessing its lean and backfiring through the carbs, hesitation, and backfire...then u pull through it and its fine? Im gonna say its lean for some reason and if it started with changing the carbs, you gotta go back there and be sure they are right.

Mark
. You can hide this ad & support this site by upgrading to a Gold Membership ~ click here for more info

Reply to this topic or post your own questions!

Members Sign In if you've already registered, or

Register a New Account

Registration is free and takes less than a minute

Having trouble posting or changing forum settings?
Check the Forum Help File (FAQ) or contact the webmaster.


Join The Club

Sign in to ask questions, share photos, and access all website features

MGExp Menu

What's New

Membership

Forums ->

MGB & GT

MG Midget

Buy, Sell & Trade

Vendor Market

MG Engine Swaps

Original MG

MGA

MGC

MG Magnette

1100 & 1300

T-Series & Prewar

Modern MGs

MG Motorsports

Member Meetup

MG-2015 Event

Other Vehicles

Off Topic

Clubs

Forum Search

Random Topic

Latest Posts

Live Chat

Calendar

Journals

Tech Library

Car Registry

Cars For Sale

Model Info

Motorsport

Directory

Member Map

MGExp Store

Search Site

Advertising Info

Smartphone quick link
mgexp.mobi

Adjust Text Size

Larger Smaller
Reset Save