MGExp

MGB & GT Forum

What is this tiny part (capacitor?) broken off, that's making car run so badly?

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

Nicecar Avatar
Nicecar Gary (ex "Harv") G
Victoria, BC, Canada   CAN
1980 MG MGB "Red On Red On Red"
Yesterday, 50 miles from home, passed a metal fabricator artisan. A STEEP single paved lane led up to his home. Just after entering property is this wonderful gate, with a sign that said: "Gate may be closed for picture taking". In order to get car in a good position, I had to turn it around. In doing so I had to go in REVERSE on some steep grass. My wheels spun, and later noticed I'd left two 12" ruts, grass removed, down to earth. I'm thinking something (dirt or small rock) as a result of spinning, hit this and broke it off, yet there was not a speck of mud, oil or grease on it.

I found it as shown in pic two. Close up make it appear as a capacitor. This was not there when I left house in AM.

Starting car was unusually hard, with it SOUNDING IF ONE CYLINDER WERE MISSING, BUT A TELLING ASPECT, was that unless I kept my foot on gas keeping RPM's above 2500, idle would drop to 0 in a second.

At 50 mph driving home, saw deer on road and in the one second I moved foot off gas to brake, engine died. Was able to restart by popping clutch. In city at traffic lights, I needed to keep revving from 3 - 4 K RPM to keep it from stalling. Going up hills, I didn't have normal power, and needed to downshift earlier than normal to keep revs up. In past I could go up smaller inclines at 2200 RPM, but not now.

On part, you can see one end has 3 holes where it was torn off something, and other end appears to have wire protruding a few mm. Metal is shiny, more so than ZS. 25D points dizzy from Jeff 3 years ago. (ie. cap inside).

Years ago Basil mentioned in-line spark plug checkers. I carry in boot, & attached all four, and got even good light indications; checker light an orange colour. (I'm assuming is good indication).

What this is, where it's from, what it does, has me stumped. And why a miss?

Images:
"Le Jacque" Survives!.
Where part found.
Front & back CU. / As only 4 images allowed, I shot part this way.
4 plugs; 1-4, left to right. (Right #4 plug = others - flash fading off.)

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

Attachments:
And Le Jacque Survives!.jpg    89.1 KB
And Le Jacque Survives!.jpg

Where Part Found.JPG    44.9 KB
Sign In or Register to view this photo
Mystery Part CU copy.JPG    45.6 KB
Sign In or Register to view this photo
Plugs after 50 Mi Driving.JPG    56.7 KB
Sign In or Register to view this photo
Rod H. Avatar
Amity, Oregon, USA   USA
1964 MG MGB
1968 MG MGB GT
Not sure what that part is, but the symptoms could be from a bad vacuum leak.



I can't understand why people are frightened of new ideas. I'm frightened of the old ones. John Cage

'63 MGB
'68 MGBGT
'80 VW Vanagon Kombi
'09 Mazda 3 with 5 speed manual

Steven 67GT Avatar
Steven 67GT Steven Rechter
Imperial Beach, California, USA   USA
I think that part is a red herring.

It's either fuel/carb or vacuum leak.



There are no bad days at the beach.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
warekl Avatar
warekl Silver Member Keith Ware
White Bear Lake Mn, USA   USA
1973 MG MGB GT
1979 MG MGB
Backing up, did you partially plug your exhaust tail pipe or crush the steel fuel line under the car?



USMC ... Semper Fi
79 RB Lowered, HS4s by Dave Braun & "Schlemmerized" 25D Dizzy, 9.5:1 CR, Mild Performance Cam, 18V with OD Tranny.

73 GT in Black Tulip

course2kid Jeffrey Johnson
Fountain Valley, CA, USA   USA
1979 MG MGB "Lucy (Lucifer)"
x2 what the above posters said - I don't think that part is from your car unless it came from some aftermarket add on parts. With factory wiring, the only electrical parts on the driver side of the engine bay are the induction heater, the brake system failure switch, the brake light switch, and the TCSA solenoid valve and the part you found is definitely not from any of those.

Bruce Cunha Avatar
placerville, California, USA   USA
Looks like what is left from a radio suppression capacitor that would have been mounted on the coil. See if there is a wire coming off the coil with a black plastic cap on it.

That would not make the car run like you described.



Bruce E. Cunha

Marathon Silver Member Mike Standring
Berlin, Berlin, Germany   DEU
It's a metal spider's egg. If you look carefully, you'll probably find dozens of the things.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Vern Avatar
Vern Vern Smith
Athol, Idaho, USA   USA
Looks like a light bulb socket that got torn off of the mount/wiring.



If you pretend it ain't broke, you don't have to fix it!

Vern Avatar
Vern Vern Smith
Athol, Idaho, USA   USA
If you still have the ZS carb, check for a torn diaphragm or a stuck "choke".....enrichment system. Also, pull off the air filter housing and make sure the piston slides smooth and easy with no sticking. Definitely sounds fuel/vacuum related. If you haven't already, buy the carb rebuild kit. Simple to do and lots of posts here to help.



If you pretend it ain't broke, you don't have to fix it!

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Be Coming Avatar
Be Coming Kelvin Dodd
So. Calif., USA   USA
I'd be looking for the hole in the intake manifold that what appears to be a used capacitor was plugging. The image you posted doesn't show the top of the intake manifold where the EGR and gulp valve would be fitted. My guess is that one of those has been removed and the resulting hole then plugged with the cylindrical thingy. That would account for the rough running, as the symptoms do sound like a lean mixture due to an air leak.

Kelvin.

Nicecar Avatar
Nicecar Gary (ex "Harv") G
Victoria, BC, Canada   CAN
1980 MG MGB "Red On Red On Red"
KELVIN GOT IT!!! - but another hose too off.
Honoured Kelvin took time; I'm so appreciative of Moss, except for cost of mailing to Canada.

Kelvin; talk to Kevin about relocating in Canada; so many reasons to, & I'll buy more: at least $200 / year:-

It's past 14:00; I need to eat lunch before explaining.

I'm feeling Sheepish that after 23 years owning, I have so little understanding of vacuum system and what leaks can do.

When I posted images of plugs, they did look lean to me. Right?



Edited 1 time(s). Last edit at 2017-10-11 04:26 PM by Nicecar.

Ex-Calif Avatar
Ex-Calif Gold Member Dan D
Cincinnati, Ohio, USA   USA
1968 MG MGB GT "Bart - Yellow And Naughty"
1977 MG MGB "Red Betty"
2012 Jeep Liberty "Tank"
2014 Hyundai Accent "Skate"
To me the plugs looked OK but your relatively short drive would not have necessarily set a plug color.

Also presuming you have the original ZS carb (based on the air intake) you are probably running rich when the manifold isn't leaking like a ton of other ZS owners.



The goal - Reliable summer driver interspersed with mechanical tinkering...
Motto - "Driving fifty in the twisties..."
On Mods - It's your damn car - Do what you want. Haters gonna hate...
On SUVs - Drive your B like a soccer mom is texting her friends about how she wants to kill you...
Red Betty - http://www.mgexp.com/registry/GHN5UH418165
Bart - http://www.mgexp.com/registry/GHD4U146898G

Gary G Avatar
Toronto, Ontario, Canada   CAN
Nicecar, are you going to post a picture of the intake manifold hole? I have the same engine but different carb, I wonder if I have a capacitor in that spot too!

29desoto Avatar
29desoto Gold Member Wayne Sanders
Outside Otis, OR - in the woods!, USA   USA
1953 MG TD
1965 MG MGB V6 Conversion "Carmine"
1977 MG MGB "Ole Yeller"
1979 MG MGB "Kermit"    & more
It sounded like the vacuum leak I had on the way to San Diego. Exactly the same symptoms, and mine turned out to be a vacuum plug gone south.



Wayne Sanders
Rose Lodge, OR
(TD 4288)

"I don't care to belong to any club that accepts people like me"-joined Willamette Valley Club in 2011

77 MGB - Four tone paint -Pertronix - hood props - cheap tires - new springs all around - mixture of poly and rubber bushings- fuzzy seatcovers - stereo out of old F150 pickup -runs flawlessly and drives nice.

78 MGB - Done right by a good PO, and I only bought it. Tell Jim how nice it is. But I did put in a Datsun 5 speed.

53 TD Mark II - a work in progress.

79/65 MGB - Carmine- V-6 - T-5
This car is now very nearly completely done. Sure to find something else, but not now.........

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions

Members Sign In   or   Create an Account

Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster





Join The Club

Sign in to ask questions, share photos, and access all website features

Your Cars

1980 MG MGB Limited Edition LE

Text Size

Larger Smaller
Reset Save

Sponsor Links