MGExp

MGB & GT Forum

19 72mgb run bad

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

Tcd72mgb Timothy Dillon
Macomb, Michigan, USA   USA
Hello everyone maybe someone can steer me in the right hav owned my 72mgb for over 30 years always been able to keep it running well last week carb started leaking fix 0 ring reset carbs thought all was fine
Well now does not hav power and when giving it gas it spits out of the carb any thoughts would be welcome thanks

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
RAY 67 TOURER Avatar
RAY 67 TOURER Ray Marloff
Fort Bragg, CA, USA   USA
1967 MG MGB "My Girl"
Sounds like a faulty needle and seat. Replace it with one that has a Viton tipped needle. RAY

darnoc31 sandy sanders
hudson, florida, USA   USA
Have you synchronized carbs. Possibility that only one carb is opening.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
Ex-Calif Avatar
Ex-Calif Gold Member Dan D
Cincinnati, Ohio, USA   USA
1968 MG MGB GT "Bart - Yellow And Naughty"
1977 MG MGB "Red Betty"
2012 Jeep Liberty "Tank"
2014 Hyundai Accent "Skate"
What o-ring did you replace?

When you say you reset the carb - what did you actually reset and to what specification.

Fuel spitting out the inlet sounds like float set too high.

In reply to # 3591167 by Tcd72mgb and when giving it gas it spits out of the carb any thoughts would be welcome thanks



The goal - Reliable summer driver interspersed with mechanical tinkering...
Motto - "Driving fifty in the twisties..."
On Mods - It's your damn car - Do what you want. Haters gonna hate...
On SUVs - Drive your B like a soccer mom is texting her friends about how she wants to kill you...
Red Betty - http://www.mgexp.com/registry/GHN5UH418165
Bart - http://www.mgexp.com/registry/GHD4U146898G

Tcd72mgb Timothy Dillon
Macomb, Michigan, USA   USA
thanks i thought about that awhile back switched to grose jets i should hav replaced them with the stock ones,people hav said maybe a bad valve but iam not so sure iam going to do a compression check and see thanks

Tcd72mgb Timothy Dillon
Macomb, Michigan, USA   USA
hi replaced O ring on bottom of carb set jet height even with jet body then backed off 2 turns started up ran great then after about an hr. started running rough bad idle loss of power i think it might be the temp comp senor being that i took everything apart to clean

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions

Members Sign In   or   Create an Account

Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster